Bluesound Node Issues After the Firmware Upgrade

I know a lot of folks own various versions of the Bluesound Node streamers. My Node 2 seems to have survived the 3.10.0 upgrade but my N100 is no longer connecting to the WiFi. The recent maintenance release 3.10.3 did not help.
Anyone else having issues with their Node devices?  
No connection for 1 day
The next day a blinking connection. if you had fast thumbs you could listen to one thing .

Then it declared Nother update needed.

Will know tonight if fixed
That would explain my N100 going solid red.
Reset fixed it.
Good luck with no power switch, no reset switch, no access to cord plugs.
As with all thiings computers a reboot fixes 99% of problems.
Of course Lenbrook could inform users.
There has been a Bluesound upgrade problem for the last week or so.
They have implemented a new upgrade to address the issue.
Node 100's ( the original), were the primary victims.
The latest upgrade- see the Bluesound website, fixes it- as far as I can tell.
However, I needed to manually install the update via USB. The upgrade via the Bluesound App, caused it to brick.
I have found this to be the Achilles Heel of Bluesound.  I don’t even accept the upgrades but this started automatically.  My Node2 is currently dead in the water
I updated my Node2i this week. It's connectivity is more stable now.

@mahler123,  Dead? Please explain.

I haven't had time to play around with it, but the BluOS page is greatly truncated and I can't get anything to play on the Node, which is in my basement system.  I know from painful experience, as a long time Bluesound owner, that when this happens it means something went amiss during an update.  I have literally spent hours through the years trying to get these units out of update Hell.  The CS used to be helpful but  has gotten progressively worse though the years and I don't bother with them anymore.  
   I have 3 systems in the home and was originally interested in the whole home aspect of Bluesound but have had multiple issues.  I even had my house ethernet wired largely to make these units work better and that helped as did refusing to do updates but now the updates start on their own.  I gave up on one Node that I couldn't get to restart and it resides in a recycle bin somewhere.  It was replaced with a Bryston BDP3 which while it has it's own issues is generally fixable and sounds much better, but I have kept the Vault and another Node2 for the other two systems.
I really don't miss the Whole Home thing...if I am busy moving from level to level in my House I am usually so preoccupied by the tasks at hand that I am not seriously listening to music.
   I realize that Bluesound is priced to a point, but it isn't bargain basement priced, and it's puzzling to me that they uniquely have been vulnerable to problems after updates for years and haven't done diddle to fix it.  Considering the size of their market share for the product category, and the size of the parent company, I really find this inexcusable
I tried downloading the newest release 3.10.3 using the ethernet connection (vs. WiFi) and it revived my N100. There’s a lengthy discussion on the Bluesound Help Center forum about this subject and one of their support guys walked me through the process and it was very helpful. My Node2 worked fine after the upgrade without any additional intervention. BTW, this recent (3.10.0) upgrade was the only time I had issues with my devices. All in all the units have been rock solid over the several years I've owned them.
I was having dropout issues with my Node 2, which I attributed to the fact that I'm using wifi and it's in the opposite corner of my house from my router, but since the recent update it hasn't dropped out once.  Knock on wood, fingers crossed, and all that stuff.
To add to the frustration, when connection is not possible, you can’t even send a support request because the the blueos app is so truncated in the failure mode.

To effectively use the node streamer, you have to depend on *2* computers to run as expected. The bluesound AND your iPad or phone app etc. I also have constant bluetooth connection problems each day at start up. In retrospect, I would have much preferred a remote to at least decrease these failure rates by 50%.

I am thankful that i still have hard media CD s and an oppo to fall back on.
I have a node 1 that froze up a couple of weeks ago. I just received a new node 2i. I use the node 1 as a paper weight. Nothing worked to revive it. Maybe I’ll try the reset again in a few days.
"I have a node 1 that froze up a couple of weeks ago..."

rocray, if by "freezing up" you mean its stuck in a red LED mode, try reading through the link below, particularly the last few posts and see if that helps. It helped me with my Node N100.
Good luck.
kalali, thanks for the link. I did try a reset last night,it did start blinking for 20-30 seconds,and then went back to solid red. I will try the reset again ,but this time I’ll connect it via Ethernet cable. The funny thing is my Node froze and I ordered a 2i before this potential fix. Isn’t that the way life goes sometimes? 
I have both a Powernode 2 and the original Powernode N150.  The 2 handles updates just fine, but the N150 will go into a solid red light.  Sometimes connecting by wire will finish the update, but I had to do the last 2 updates via USB stick.  The instructions are on their web page.  Try the USB route before you do a reset.
One little trick for the rest to work is you have to hold your finger on the button before you plug it in the outlet, and keep holding it until it starts flashing red. It should then turn blue if connected to ethernet or turn solid green if on the WiFi. Then just follow the set up process for WiFi...
I really love my Vault 2i but the past few upgrades I had issues.   Works fine now but after the last update I had to reboot the unit , it would not communicate with my tablet.
Bluesound fixed the issue with the latest firmware.
I had to manually install it, but it seems many have done it through the app successfully-per the Bluesound forum.
Well,it seems the update will resurrect the Node 1. Looks like I may be putting the Node up for sale,now that it will be working again.  Truly impeccable timing. Oh well . If I had waited about two more weeks,it wouldn’t have cost a thing. However,I did get a brand new 2i.
Well,I tried the factory reset. That worked. I first hard wired it to the router, and the update worked. Unplugged the Ethernet cable and tried the setup via WiFi,and SHAZAM!!!! 

    Now the very difficult part of this problem. When the node went down,my lovely wife told me,” Go ahead and just order a new one”. 
 Which I did. The new 2i showed up days before Bluesound offered the update/fix. I guess I’ll sell the Node n100 and put the proceeds in our joint account instead of my mad money account. Why do things have to be so complicated??
Oh, ye of little faith...😉

The fact that Bluesound is still working to keep all previous iterations of the Node current means that they will probably do so in the future. And, considering how old and how little the original Node's cost, it seems an honorable way to provide longtime customers support.

I wish I knew that they were going to offer such great customer support for such an old product. Oh well,first world problems.