Rotel RSX-1058 Won't Respond to Remote Commands

Have any forum members experienced a situation where your Rotel receiver suddenly stopped responding to remote commands?  I haven't made any changes to my system, set-up or remote (I use a Logitech Harmony One) but my receiver is unresponsive to any and all remote commands.  I haven't been able to find the OEM remote to perform a test but it seems more likely to be a problem with the receiver; it worked perfectly one minute than it just suddenly stopped responding.  Any info on similar experiences is appreciated.
I assume you checked the batteries in the remote.  I had two friends buy Harmony remotes and both failed within a year, so not sure I'd be too quick to blame the Rotel.  Maybe try unplugging the receiver for a minute and then try again.  

Agree with soix, remote is likely the problem. Even if you had this problem with the OEM remote, it would likely be the remote. Not saying it couldn't be the receiver, but would look at the remote first.

I had a similar problem with a remote a few years ago. The bluetooth xmitter on my phone interfered with it.

Another time, a new light bulb in the same room interfered with the signal. The up-volume command would issue but not stop when my finger released the button. Crazy jumps to the volume knob on that one.

Perhaps something else - new - is creating an issue with the remote signal beam. 

(Of course, I have more than once incorrectly installed the batteries in the remote. So there's that.)

Good luck.

Thanks to everyone for the prompt responses, it's much appreciated and I didn't honestly expect to receive any advice!

I guess I ruled out a malfunctioning remote as a possibility and was hoping for good news on a simple fix for the receiver.  Here are the steps I took to troubleshoot before posting to the forum:

As soon as my Rotel stopped responding I powered it down using the main switch on the back, unplugged the power cord and waited 10 minutes per our local Rotel dealer.  No dice, still nothing. 

I then launched the Logitech software on my Mac, deleted the Rotel A/V receiver from the Harmony One list of devices, plugged the remote in to my Mac w/USB, updated the remote and confirmed the device had been deleted from the remote.

Next, I added a new device to the remote (Rotel RSX-1058, obviously), plugged it back in and updated it using the Logitech software.  Still no luck.

My Harmony One still works flawlessly with my Rotel RDV-1092, Comcast/Motorola cable box, Samsung Smart TV, XBOX One and my iMac.

Makes me think it's not the remote though I wish it were, it's a much easier fix and won't leave me without a receiver should i need to send it out for repairs.

  "Receiver-less for 2 months while my Rotel is sent in for $500 in repairs"
I have the same problem with my Rotel RSP-1068 preamp. What did they fix \ replace?

I had an Arcam400 receiver after awhile the remote stopped responding, I read the manual instructions and found out that I had to press the AMP button on the remote for it to activate the remote again and after that it started to work, this happened occasionally but the AMP button served as an unlocking system for the remote for what I don't know but that's how it was it might help to look at your manual instructions.
good luck!