Roon "Lost control of audio device"?

All of a sudden for the past couple of weeks, I can’t get through 2 minutes of a song without receiving an error stating, “Roon lost control of the audio device.” I use a Spectrum modem and router. Spectrum  replaced my router, but I continue to receive the same error. Sometimes I hear what sounds like static coming through my speakers, right before the error pops up and the music stops. I’ve tried resetting my Antipodes S40 music server and my Chord English Electric 8 Switch. How do I correct the issue, because I can’t listen to music? Can anyone recommend a good router/modem?


I'm running ROCK which is Roons OS on a NUC. I had the same problem the only thing that fixed it was reinstalling the OS but it's easy to do with ROCK. Can you log in to the OS and find Roon core with webmin and do a reinstall ? 

When Roon refers to "Audio Device" that's the Roon endpoint streamer/renderer, When you select an "audio device" in the lower right corner, it's where Roon is going, not the source of the music (i.e. a streaming service or a NAS with locally stored files if you have any). 

So that makes me suspect it's an issue downstream between your Core and your endpoint. I would look for diagnostics in the endpoint's software look for error logs, etc. and contact their support team. or post any such findings in a Roon Support ticket. Cheers,


This happened to me when I was using a smart switch.  Now using $20 tplink dumb switch and no issues.


Thanks so much for your response. 

I receive the error when playing files stored on my Antipodes S40(Samsung EVO SSD). Could it be my switch or USB cable? Sometimes it plays a song without error and other times I receive the error every one to two minutes. 

Is this over Ethernet or Wifi?

How long is the wiring? Is it wired in the walls?

My Antipodes S30 and S40 are hard wired to my Chord EE8 switch. The Ethernet cables are only 1m in length. Music will not play for more than 2 minutes without receiving the error, Roon lost control of the audio device. Sometimes I loose music all together and just hear "white noise"?

@ricred1 Do you also use any streaming service such as Qobuz or Tidal? If so, do you get no errors then? If not, how about a Qobuz free trial and report back if the error is on both local file playback and streaming service or not. 

If you know the error is isolated to local playback, I agree @vonhelmholtz suggestion to try a "dumb" switch vs. smart may eliminate it. I used to a Pro series Netgear that caused some weird errors. I also replaced it with a $20 TP-Link recommended by Andrew at Small Green Computer and the issue was resolved. Cheers,


If nothing else works you could try RAATServer refresh.


  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location 5
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

I talked to Mark from Antipodes last night and he made some adjustments to my S30 and S40 music severs. In addition, he told me to remove the Chord EE8 switch and plug the S30/S40 directly into the router. I’ve used the Chord EE8 switch for over a year with zero issues, so I don’t know why removing it seems to have eliminated the issue.?

Some smart switches are like a drunken traffic cop outside a stadium after the game. They think they know how to handle it.