Problem With Innuos Sense - Won't Play Selected Song?

I have an issue with Innuos Sense (latest version) where no matter how I select a song, it most often will not play.  I can trying playing a single track or I can try playing an album, and I can try using the mobile app or on my desktop PC on the same network as my Zenith Mk 3 (which is totally up to date).  When I try to play an album, it will try and fail to play tracks before moving on the the next, until one finally plays. After finding a song on the album that plays, it will fail at playing the subsequent track (no shuffle is not on).

I'm running my Zenith as a standalone endpoint.  Of note, I can use Roon instead of Sense and Roon has no issues (other than Sense sounds better).

I'm logging a support request with Innuos but just wanted to see if anyone has had this issue and if there might be a quick fix? 




I should also mention that while I primarily listen using Tidal streaming, the problem is present and no different when playing local files stored on the server as well.

Yeah mine used to work. At least the majority of the time but once in a while this would happen. I somehow don’t think it is a software version thing but could be wrong.

Also - if I repeatedly try playing a track and letting it fail, eventually it will work - sometimes after 20 tries or so.

I think having trouble with one song like that tends to be a streaming issue, perhaps cache confusion if there is such a thing  anyway, i've seen it on other platforms.  rebooting router and modem seemed to help.  Maybe reboot your streamer too.




Try rebooting your Zenith Mk 3. I had the same issue but all gone now after the reboot.

Hope this helps,

@jon2020 Unfortunately I’ve tried rebooting several times, to the point of disconnecting power, and the problem remains.  

Also, @carlsbad2 it doesn’t appear to be a streaming issue, as the problem also also is present when playing files of the internal hard drive.

I guess it’s not a simple/common issue like I was hoping… thanks anyways!

Innuos is in touch with me now and I’ve sent them the system log files at their request.




I've had this happen to me, but it was nothing related to Sense, but my Internet service was either throttled due to service/maintenance, or there was a fault withe my local connection hub.

Just a thought

Post removed 

I'll be interested to hear the resolution to this one. Given the issue persists while playing from local disk and plays correctly with Roon would seem to eliminate the network as the culprit. Was thinking you might not get a response given the holiday but Innuos is based in Portugal:) Hopefully you hear from them soon. 

Post removed 

Yep, Innuos is being really prompt. I have a remote session with their tech support scheduled in about 9 hours (after previously sending system logs to them). Agree, shouldn’t be a network issue since playing local files has the exact same issue. And, I doubt reinstalling the app will do anything. Because, the same issue happens when I attempt to control music through from my desktop PC (which is not using a locally installed app at all).


@gertrude09, you win this thread.  You called it with the “confused cache”.  I was inspired by this to go to Advanced Settings and select “Clear Queue Cache”.  That has seemed to totally fix the issue….  I suppose the queue must have become corrupted or mixed up at some point?  Everything works now.

Post removed 

@nyev , et al,

Apologies in advance to gertrude09 if I am wrong, which is totally possible, but:

@gertrude09's post seems like one of the bots we have been experiencing lately?  If not why does her second post ever on A'gon, made the same day she joined, end with an advertisement?

And reset your myfedloan customer service.

What’s weird is that the audio advice given seems to have worked.

I think @gertrude09 may be a bot.  This is the first time I've seen a bot taking part in a coversation on this site (that I know of).  Anyway he joined yesterday and his first post was a rephrase of my earlier post and his second post had a link to "myfedload customer service".  I wouldn't click on that.


@carlsbad2 you are right, probably a bot, you posted that first, about the cache confusion….  

@nyev I don't worry about getting credit for it, I worry about bots.  When you gave him credit, I said to myself, "Self, that sounds like what I wrote."  When I reread it I suspected bot and confirmed he joined yesterday and then he posted a link to a scammer later.  

I believe in the old Harry Truman maxim, "It is amazing what you can accomplish if you don't care who gets credit for it."  --Jerry

@jetter We figured out that the audio advice given was just a paraphrase of my advice given earlier (which was just a guess on my part).  not worried about credit at all but just want to explain how this bot seemed to have useful advice.

@carlsbad2 , true, it’s amazing what you can accomplish when you let others take the spotlight.  In this case, an egotistical bot stealing the glory :)

Is a bot a he or a she?

Are they related to the bits?

Have you heard that the bits are separated?

I could go on but you guys would eventually hire John Wick.